Strange bugs on launching the game on Ubuntu
2020-12-04, 03:16 PM
Strange bugs on launching the game on Ubuntu
I tried to run ACR on my computer. It's the first time I try to do it from this computer

The first time, I only got a black screen with a background music. I tried to interact but nothing responded This look like what happened with Tomatenquark (a fork of Sauerbraten), and, like with Tomatenquark, I had to reboot my computer.

Next, I added fullscreen 0 in the file default.cfg. (with Tomatenquark, deactivating fullscreen in the config files was the fix for this problem) This just made things stranger the game tried again to force the fullscreen mode (apparently ignoring the value of the variable fullscreen), changing the screen resolution to 1024x768, then crashed. I had to revert after screen resolution

Luckily, I had to launch it from command line. here is what I got :

Using home directory: home
Adding package directory: acr
init: sdl
init: net
init: world
init: video: sdl
init: video: mode
init: video: misc
init: gl
Renderer: Mesa Intel(R) UHD Graphics 630 (CFL GT2) (Intel)
Driver: 4.6 (Compatibility Profile) Mesa 20.2.1
init: console
libpng warning: iCCP: known incorrect sRGB profile
init: sound
Audio devices:
Sound: OpenAL Soft / OpenAL Soft (OpenAL Community)
Driver: 1.1 ALSOFT 1.19.1
init: cfg
alias demo is a constant and cannot be redefined
(file: config/admin.cfg)
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  153 (XFree86-VidModeExtension)
  Minor opcode of failed request:  10 (XF86VidModeSwitchToMode)
  Value in failed request:  0x3000010
  Serial number of failed request:  208
  Current serial number in output stream:  210
AL lib: (EE) alc_cleanup: 1 device not closed

I added to the file default.cfg two lines, scr_w 800 and scr_h 600. Just to chek what happen. It merely changed nothing. I got exactly the same console output and the screen resolution changed again to 1024x768.

However, unlike ACR, AC work fine on my computer. I checked the version, it's the version, the latest one. I suspect the reason is I deactivated fullscreen in the setting menu before a faulty change in a system update. Visibly, since that update, nothing works in fullscreen.

Post Reply Quote this message in a reply
2020-12-05, 12:29 PM (This post was last modified: 2020-12-05, 12:32 PM by Victor.)
RE: Strange bugs on launching the game on Ubuntu
Could it be graphics driver issues?

Could it have been a bug introduced in a later version of libsdl, which we depend on?
ACR is typically compiled with the latest version of dependencies, so it might have a different version of libsdl compared to AC and Tomatenquark when they were compiled.

If you are using the executables from the ACR package, does compiling it manually make a difference?

Best regards,
Your antithesis compares favorably with any high magnitude of pwnage. (-you > |p|, you < -|p|)
My antithesis compares favorably with _that of_ any high magnitude of pwnage. (|-me| > |-p|, |me| > |p|)
Post Reply Quote this message in a reply

Forum Jump:

This forum uses Lukasz Tkacz MyBB addons.